Troubleshooting message

System Requirements

Minimum system requirements

In order to view or comment on planning applications you will need to ensure that your browser is up to date.

You can do this by downloading the latest version of Internet Explorer, Mozilla Firefox and Google Chrome or the minimum system requirements are set out below.

The requirements are as follows;

Internet Explorer 11

Mozilla Firefox 27.0

Google Chrome 30.0

Safari v5 on iOS and v7 on OSx 10.9

Opera 17.0

Windows 7

If you still experience issues accessing the site please email our system administrator;

janine.housden@braintree.gov.uk